AWS outage impacting SmartBear ID logins and email notifications

Incident Report for BugSnag SaaS at bugsnag com

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 10:59 UTC

Monitoring

An AWS outage occurred, preventing SmartBear ID logins to the BugSnag dashboard and notification emails from being sent. We are monitoring the situation, but we expect that logins and email notifications will now continue to work as normal. All other functionality remained operational throughout the incident.

The AWS incident can be tracked here: https://health.aws.amazon.com/health/status#multipleservices-us-east-1_1760954629
Posted Oct 20, 2025 - 10:11 UTC
This incident affected: BugSnag Dashboard.