BugSnag Marketing Site Down

Incident Report for BugSnag SaaS at bugsnag com

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 17:43 UTC

Identified

Due to a reported global Cloudflare outage, the BugSnag marketing site may currently be inaccessible for some users. This will not impact any BugSnag dashboard functionality or BugSnag APIs. Users can still access the BugSnag dashboard by navigating to app.bugsnag.com
Posted Nov 18, 2025 - 14:40 UTC