Issues with BugSnag Dashboard

Incident Report for BugSnag SaaS at bugsnag com

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 09:33 UTC

Update

We’re still investigating the root cause.
Posted Nov 07, 2025 - 03:34 UTC

Update

We are currently experiencing some issues with loading errors in the BugSnag dashboard. Users may experience delays when trying to view their errors.
Posted Nov 07, 2025 - 03:30 UTC

Investigating

We are currently investigating this issue.
Posted Nov 07, 2025 - 02:59 UTC
This incident affected: BugSnag Dashboard and BugSnag Error Reporting API.